Service interruption
Incident Report for Blueprint Solutions
Resolved
All PDF and IncomeXpert PLUS services have been restored.
Posted Jul 17, 2024 - 20:23 EDT
Investigating
We have detected the PDF service and parts of IncomeXpert PLUS processing are down. Investigation is underway.
Posted Jul 17, 2024 - 19:23 EDT
This incident affected: IncomeXpert, IncomeXpert PLUS, and IncomeXpert API.