The software service dependent on AWS has been restored as of 3:00pm today. Previously we have noticed intermittent functionality, as such we are continuing to monitor and will close out this alert when functionality has remained stable for multiple hours.
Posted Oct 20, 2025 - 15:06 EDT
Update
The Amazon Web Services (AWS) outage still continues to impact our 3rd party software service used for supporting our IncomeXpert PLUS product. Ref: https://health.aws.amazon.com/health/status
We continue to monitor the status of AWS as well as our 3rd party software service dependent upon AWS.
Posted Oct 20, 2025 - 14:34 EDT
Identified
Due to the AWS outage, a number of SaaS companies hosting on their servers have been impacted. A notification system used by IncomeXpert PLUS is currently impacted and as such loans flagged for further QC review are unable to be processed in a timely manner.
These loans may take longer to process due to the outage of the dependent system.
We are monitoring this situation and will provide updates as and when our dependent services come back online.