Blueprint has completed its monitoring of this issue. We have current corrective actions to address the original issue which were effective. These were restarting stuck/unresponsive server instances. Going forward we will adjust the planned scaling schedule to earlier in the day and avoid scheduled scale up events during the workday.
Posted Feb 18, 2026 - 16:24 EST
Monitoring
The IncomeXpert API is now operating nominally. The Blueprint team will continue to monitor systems throughout the day to ensure the system remains nominal.
The preliminary root cause of the issue indicates a subset of server instances are experiencing high RAM utilization after scale out and becoming slow to respond. This impacted a fraction of the API server instances, hence some clients saw nominal performance and other experience degraded performance.
Posted Feb 18, 2026 - 12:37 EST
Update
IncomeXpert UI users have nominal performance restored. The degradation to the API is still being investigated.
Posted Feb 18, 2026 - 10:48 EST
Investigating
We have identified a slow response situation impacting some users. Users may experience slow or variable response when using the UI or API. Our team is investigating and will update status periodically until resolved.
Posted Feb 18, 2026 - 09:29 EST
This incident affected: IncomeXpert and IncomeXpert API.